问题,使用传统的模块化方法安装PHP5.1.* + apache 2.2.2 后不能启动, C4uR5U
vTEkh0Ys
提示: |K-lgrA
"Cannot load C:/php/php5apache2.dll into server: The specified module could not be found." rQm
7tpZE+OX
D ` X6'PP
原因: D5b_m|7%
p4EItRZS
PHP压缩包里的php5apache2.dll只适用于apache2.0.* NETC{:j
oI~Qo*4eh
解决方法: 7qz-RF#s8
EXcj F
下载 这个文件 并解压.共有三个文件. @b{u/:y
5;
[|k$ v
vcredist_x86.exe [\
YP8^..
php5apache2.dll @<=#i
httpd.exe.manifest F s\P/YX
ZcRm5Du~:
05 Q8`
好,开始 JW[\"`x!
:t
S"sM
1.将 php5apache2.dll 覆盖掉你原来PHP目录下的 php5apache2.dll 文件. I?g__u=n~
r(T/^<
2.将 httpd.exe.manifest 文件复制到你的apache安装目录下的bin文件夹下. Q3q.*(#
==Mi1Q#5C
3.双击运行vcredist_x86.exe安装.(如果您的系统里已安装了 .NET framework 2.就可以省掉这一步) M9g\/]Io;
N>Y50
完成!去重启你的apache2.2试试吧.