问题,使用传统的模块化方法安装PHP5.1.* + apache 2.2.2 后不能启动, imuHSxcaV
:udZfA\sW
提示: 05DtU!3O
"Cannot load C:/php/php5apache2.dll into server: The specified module could not be found." ]z@]Fi33Y
R|yTUGY
I*t}gvUt9
原因: _J`M>W)8
'7%9Sqx
PHP压缩包里的php5apache2.dll只适用于apache2.0.* ?q7Gs)B=^'
S!bvU2d
解决方法: '?[msX"aqa
s@9#hjv2
下载 这个文件 并解压.共有三个文件. EH%j$=@X
[#V!XdQ,
vcredist_x86.exe 3 g!h4?^
php5apache2.dll (9h{6rc=I
httpd.exe.manifest P|4a}SWU
<7h'MNf&
Z.:A26
好,开始 WV5R$IqY
HKf3eC
1.将 php5apache2.dll 覆盖掉你原来PHP目录下的 php5apache2.dll 文件. ? -tw *2+
{K}+$jzGVt
2.将 httpd.exe.manifest 文件复制到你的apache安装目录下的bin文件夹下. #]a0 51Y
q\G@Nn^
3.双击运行vcredist_x86.exe安装.(如果您的系统里已安装了 .NET framework 2.就可以省掉这一步) ]z$<6+G
+d.Bf
完成!去重启你的apache2.2试试吧.