8、防御PHP木马攻击的技巧
41=H&G& G9-ETj} d#+Nef5 PHP本身再老版本有一些问题,比如在 php4.3.10和php5.0.3以前有一些比较严重的bug,所以推荐使用新版。另外,目前闹的轰轰烈烈的SQL Injection也是在PHP上有很多利用方式,所以要保证
H.|I|XRG/ 安全,PHP代码编写是一方面,PHP的配置更是非常关键。
BegO\0%+ 我们php手手工安装的,php的默认配置文件在 /usr/local/apache2/conf/php.ini,我们最主要就是要配置php.ini中的内容,让我们执行 php能够更安全。整个PHP中的安全设置主要是为了防止phpshell和SQL Injection的攻击,一下我们慢慢探讨。我们先使用任何编辑工具打开 /etc/local/apache2/conf/php.ini,如果你是采用其他方式安装,配置文件可能不在该目录。
MR,I`9P e NV?x<LNWd (1) 打开php的安全模式
e46`"}r |pZ7k#% php的安全模式是个非常重要的内嵌的安全机制,能够控制一些php中的函数,比如system(),
|BM#r fQ 同时把很多文件操作函数进行了权限控制,也不允许对某些关键文件的文件,比如/etc/passwd,
rAtCG1Vr 但是默认的php.ini是没有打开安全模式的,我们把它打开:
j]&Qai~}Y safe_mode = on
w=?nD6Xhz k waZn~ (2) 用户组安全
Y$XzZ>VW 68GH$ji 当safe_mode打开时,safe_mode_gid被关闭,那么php脚本能够对文件进行访问,而且相同
B.4e4%BBS 组的用户也能够对文件进行访问。
JtY$AP$ 建议设置为:
o|d:rp!^ ~q+AAWL safe_mode_gid = off
DcFY b|p >n/0od9 如果不进行设置,可能我们无法对我们服务器网站目录下的文件进行操作了,比如我们需要
m{ani/bt 对文件进行操作的时候。
2He R1m< Hd;NvNS (3) 安全模式下执行程序主目录
K:-jn}i?/ ~D5FnN9 如果安全模式打开了,但是却是要执行某些程序的时候,可以指定要执行程序的主目录:
]:@{tX7c m4h)Wq safe_mode_exec_dir = D:/usr/bin
An#[
+? Y?1T
XsvF 一般情况下是不需要执行什么程序的,所以推荐不要执行系统程序目录,可以指向一个目录,
ZzBaYoNy[0 然后把需要执行的程序拷贝过去,比如:
+}at#%1@ V?*fl^f safe_mode_exec_dir = D:/tmp/cmd
v+x rnz $X;OK 但是,我更推荐不要执行任何程序,那么就可以指向我们网页目录:
vh&~Y].W Y p@q20>^u safe_mode_exec_dir = D:/usr/www
5N>f lQ \C~6
' (4) 安全模式下包含文件
72RTEGy nm`(;<W 如果要在安全模式下包含某些公共文件,那么就修改一下选项:
%JPr 7 } hj"JmF$m safe_mode_include_dir = D:/usr/www/include/
kD+#| f Zs}h>$E5_B 其实一般php脚本中包含文件都是在程序自己已经写好了,这个可以根据具体需要设置。
PW%ith1)< -*[)CR-{ (5) 控制php脚本能访问的目录
:RIqA/ uPcx6X3] 使用open_basedir选项能够控制PHP脚本只能访问指定的目录,这样能够避免PHP脚本访问
:9L}jz 不应该访问的文件,一定程度上限制了phpshell的危害,我们一般可以设置为只能访问网站目录:
#t1? *4.p jTqJ(M}L open_basedir = D:/usr/www
EP;ts c{to9Lk.# (6) 关闭危险函数
Cp!9 "J: :(OV{ u 如果打开了安全模式,那么函数禁止是可以不需要的,但是我们为了安全还是考虑进去。比如,
WwoT~O8R 我们觉得不希望执行包括system()等在那的能够执行命令的php函数,或者能够查看php信息的
K)x6F15r phpinfo()等函数,那么我们就可以禁止它们:
nm\f$K>Pg % + disable_functions = system,passthru,exec,shell_exec,popen,phpinfo
ueU "v'h\ f%_$RdU 如果你要禁止任何文件和目录的操作,那么可以关闭很多文件操作
Z%ZOAu&p )CoFRqz<h disable_functions = chdir,chroot,dir,getcwd,opendir,readdir,scandir,fopen,unlink,delete,copy,mkdir, rmdir,rename,file,file_get_contents,fputs,fwrite,chgrp,chmod,chown
um]N]cCD` nTsV>lQY, 以上只是列了部分不叫常用的文件处理函数,你也可以把上面执行命令函数和这个函数结合,
WxD$k3U 就能够抵制大部分的phpshell了。
`0W"[BY
":T"Y;
(7) 关闭PHP版本信息在http头中的泄漏
MY\mo,# aBQ --Sz 我们为了防止黑客获取服务器中php版本的信息,可以关闭该信息斜路在http头中:
fh_:ung H/[(T%]o expose_php = Off
1Zk1!> ? 1$# r)S[* 比如黑客在 telnet
www.12345.com 80 的时候,那么将无法看到PHP的信息。
i)cG 7o+VhW<|5 (8) 关闭注册全局变量
3Jda: &q4~WRnzJk 在PHP中提交的变量,包括使用POST或者GET提交的变量,都将自动注册为全局变量,能够直接访问,
H/W&a2R^P 这是对服务器非常不安全的,所以我们不能让它注册为全局变量,就把注册全局变量选项关闭:
Dz.kJ_"Ro
register_globals = Off
NI:OL
当然,如果这样设置了,那么获取对应变量的时候就要采用合理方式,比如获取GET提交的变量var,
| 9 *$6Y 那么就要用$_GET['var']来进行获取,这个php程序员要注意。
g&B7Y|Es vm*9xs (9) 打开magic_quotes_gpc来防止SQL注入
h$~$a;2cR P*Jk 8MK#G SQL注入是非常危险的问题,小则网站后台被入侵,重则整个服务器沦陷,
.ozBa778u 4
}_}3. 所以一定要小心。php.ini中有一个设置:
u-n$%yDS ZA_~o#0% magic_quotes_gpc = Off
p+Bvfn tIBEja^l 这个默认是关闭的,如果它打开后将自动把用户提交对sql的查询进行转换,
4;Hm%20g 比如把 ' 转为 \'等,这对防止sql注射有重大作用。所以我们推荐设置为:
h\)ual_r[j 4K;0.W;~| magic_quotes_gpc = On
N/0Q`cQ- KVoi>?a (10) 错误信息控制
%^I 7= ,-$%>Uv 一般php在没有连接到数据库或者其他情况下会有提示错误,一般错误信息中会包含php脚本当
NJ}xqg 前的路径信息或者查询的SQL语句等信息,这类信息提供给黑客后,是不安全的,所以一般服务器建议禁止错误提示:
uY3$nlhP6 1Ogtzf display_errors = Off
}EfRYE$E ou|3%&*" 如果你却是是要显示错误信息,一定要设置显示错误的级别,比如只显示警告以上的信息:
b[n6L5P5m2 $1 Z3yb^
error_reporting = E_WARNING & E_ERROR
-xH3}K% *"/BD=INv} 当然,我还是建议关闭错误提示。
9<!??'@f m`XaY J (11) 错误日志
\q-["W34 fB; o3!y 建议在关闭display_errors后能够把错误信息记录下来,便于查找服务器运行的原因:
}LIf]YK tUfze9m log_errors = On
odcrP\S jP3 ~O 同时也要设置错误日志存放的目录,建议根apache的日志存在一起:
n
n8N 9w xr)m8H error_log = D:/usr/local/apache2/logs/php_error.log
'HvW&~i( ER]C;DYX 注意:给文件必须允许apache用户的和组具有写的权限。
ocp3J R_0 wE <PXBl\b M@.?l=1X MYSQL的降权运行
:e_yOT}} lQ.3_{"s 新建立一个用户比如mysqlstart
/KJWo0zo Tc;BE net user mysqlstart fuckmicrosoft /add
6Vu??qBy @yPI$"Ma net localgroup users mysqlstart /del
V3pn@'pr P/9|mYmsq 不属于任何组
!G~\9 #DTBdBh?I 如果MYSQL装在d:\mysql ,那么,给 mysqlstart 完全控制 的权限
EX3;|z@5; 'aZAWY d 然后在系统服务中设置,MYSQL的服务属性,在登录属性当中,选择此用户 mysqlstart 然后输入密码,确定。
|TBKsx8 v}z{OB 重新启动 MYSQL服务,然后MYSQL就运行在低权限下了。
}<P%W~ CBx5:}t 如果是在windos平台下搭建的apache我们还需要注意一点,apache默认运行是system权限,
|-AR)Smt 这很恐怖,这让人感觉很不爽.那我们就给apache降降权限吧。
c*>SZ'T\ '&xRb* net user apache fuckmicrosoft /add
ZcN%F)htm O
>&,h^ net localgroup users apache /del
WgV[,( +7)/SQM5 ok.我们建立了一个不属于任何组的用户apche。
<_Po/a!c3 W.b?~ 我们打开计算机管理器,选服务,点apache服务的属性,我们选择log on,选择this account,我们填入上面所建立的账户和密码,
U./1OZ& 重启apache服务,ok,apache运行在低权限下了。
g!;Hv q/tC/V%@( 实际上我们还可以通过设置各个文件夹的权限,来让apache用户只能执行我们想让它能干的事情,给每一个目录建立一个单独能读写的用户。
;%i.@@:IQ 这也是当前很多虚拟主机提供商的流行配置方法哦,不过这种方法用于防止这里就显的有点大材小用了。
xF9PjnWF= $0E_4#kwB 1T7;=<g` 9、MSSQL安全设置
iuq%Q\0@w sql2000安全很重要
o{QPW {7q +3f < 将有安全问题的SQL过程删除.比较全面.一切为了安全!
pe@/tO&I 3PZwz^oRh9 删除了调用shell,注册表,COM组件的破坏权限
/`VtW$9- t3$+;K( use master
</d&bS EXEC sp_dropextendedproc 'xp_cmdshell'
Rh#TR" EXEC sp_dropextendedproc 'Sp_OACreate'
[W,maTM" EXEC sp_dropextendedproc 'Sp_OADestroy'
+4p gPv EXEC sp_dropextendedproc 'Sp_OAGetErrorInfo'
Vt,"5c EXEC sp_dropextendedproc 'Sp_OAGetProperty'
*(@[E EXEC sp_dropextendedproc 'Sp_OAMethod'
rU1{a" { EXEC sp_dropextendedproc 'Sp_OASetProperty'
$y*["~TJ EXEC sp_dropextendedproc 'Sp_OAStop'
3UX} )mW EXEC sp_dropextendedproc 'Xp_regaddmultistring'
=G2A Ufn EXEC sp_dropextendedproc 'Xp_regdeletekey'
QI2T G, EXEC sp_dropextendedproc 'Xp_regdeletevalue'
D3%`vqu& EXEC sp_dropextendedproc 'Xp_regenumvalues'
vo DTU]pf EXEC sp_dropextendedproc 'Xp_regread'
'roZ:NE EXEC sp_dropextendedproc 'Xp_regremovemultistring'
x-{awP EXEC sp_dropextendedproc 'Xp_regwrite'
*[_>d.i drop procedure sp_makewebtask
AU
+2' u
kKp,1xz 全部复制到"SQL查询分析器"
w,FOq?j^k f9 b=Zm' 点击菜单上的--"查询"--"执行",就会将有安全问题的SQL过程删除(以上是7i24的正版用户的技术支持)
m)9qO7P 68LB745 更改默认SA空密码.数据库链接不要使用SA帐户.单数据库单独设使用帐户.只给public和db_owner权限.
\TBY)_[ { "&/&v 数据库不要放在默认的位置.
I806I@ix a<X<hxW: SQL不要安装在PROGRAM FILE目录下面.
^^Tu/YC9x N^.!l_ 最近的SQL2000补丁是SP4
rx#\Dc}
ojitBo~ xem:#>&r 10、启用WINDOWS自带的防火墙
bP 2IX 启用win防火墙
"i1~YE 桌面—>网上邻居—>(右键)属性—>本地连接—>(右键)属性—>高级—>
HRKe 7#e 3E361?ubM (选中)Internet 连接防火墙—>设置
Z*|qbu) v2Bks2 把服务器上面要用到的服务端口选中
r'q9N ,2%> e"% 例如:一台WEB服务器,要提供WEB(80)、FTP(21)服务及远程桌面管理(3389)
)rs);Pl S|%f<zAtJ 在“FTP 服务器”、“WEB服务器(HTTP)”、“远程桌面”、“安全WEB服务器”前面打上对号
AcYL3 v(t?d 如果你要提供服务的端口不在里面,你也可以点击“添加”铵钮来添加,SMTP和POP3根据需要打开
hQfxz,X Q
pY: L 具体参数可以参照系统里面原有的参数。
$fY4amX6Z rX#}2 然后点击确定。注意:如果是远程管理这台服务器,请先确定远程管理的端口是否选中或添加。
5sq#bvfJ o f13%[RA9N 一般需要打开的端口有:21、 25、 80、 110、 443、 3389、 等,根据需要开放需要的端口。
*5#Y[c ZIx,?E+eJ l~M86 h 11、用户安全设置
bgm$<